Plugin upgrade Failed in WordPress Using IIS 7

I found this online at http://www.whitworth.org/2009/03/10/plugin-upgrade-failed-in-wordpress-using-iis-7/ . I wanted to post it here so I could find it when I needed it.

I have modified it a bit.

How to modify IIS7 to allow WordPress to allow automatic updates:

  1. Make sure your Application Pool identity is a user account (not Network Service). This only needs to be a Domain User. Go to Application Pools under the Server in the IIS Manager and change the identity to this user. I have used the same user for multiple sites.
  2. In IIS Manager, right-click on your website –> Manage Web –> Advanced Settings
  3. Click the … button in the Physical Path Credentials box.
  4. Specify the account you are using for the Application Pool Identity
  5. Find the wp-content folder under your web site, right click and choose Edit Permissions…
  6. Go to the Security Tab, then click Add and enter the Application Pool Identity account. Give the account modify rights
  7. Click OK until you have closed out of the security dialog
  8. Reset IIS – At the command prompt run: iisreset /resatart
  9. Test plugin update

Leave a reply